system requirements

Hay House utilizes the Adobe Flash Player to deliver audio and video content. A version of Adobe Flash Player is pre-installed with most popular Internet browsers. For best results, download and install the latest version from Flash Player Download Center.

The following steps are advised if you are having trouble accessing content with Adobe Flash.

  1. Check the System Requirements below to ensure your configuration is supported.
  2. Make sure you have the latest recommended version of your Internet browser. Installing a new browser can often repair issues with browser installations, and newer browsers may also offer improved security.
  3. Remove Flash Player.
  4. Restart your computer.
  5. Download and install the Flash Player from the Flash Player Download Center.

In some cases, audio and video still may not play even if above requirements are met. Firewalls and security programs installed on your network may prevent you from accessing. Contact Hay House Customer Care for additional help.

To access Hay House content on your computer, you will need:

  • Adobe Flash Player 10.1 (.53.64) or above
  • Internet Explorer 7.0 or above, Firefox 2.0 or above, Safari 3.0 or above, or Chrome
  • Microsoft Windows XP SP2 or above, Macintosh OS X 10.5 "Leopard" or above, or Linux
  • JavaScript and Cookies enabled

In addition, you will need a broadband Internet connection for online video.

  • For Standard Definition videos we recommend a downstream bandwidth of at least 1.5 Mbps for a smooth playback experience.
  • For High Definition videos we recommend a downstream bandwidth of at least 3 Mbps for a smooth playback experience.

For the best possible experience on HayHouse.com, we recommend the following software updates:

Windows

  • 2.33GHz or faster x86-compatible processor, or Intel® Atom™ 1.6GHz or faster processor for netbooks
  • Microsoft® Windows® XP (32-bit), Windows Server® 2003 (32-bit), Windows Server 2008 (32-bit), Windows Vista® (32-bit), Windows 7 (32-bit and 64-bit)
  • Internet Explorer 7.0 and above, Mozilla Firefox 4.0 and above, Google Chrome, Safari 5.0 and above, Opera 11
  • 128MB of RAM (1GB of RAM recommended for netbooks); 128MB of graphics memory

Mac OS

  • Intel Core™ Duo 1.33GHz or faster processor
  • Mac OS X v10.6 or v10.7
  • Safari 5.0 and above, Mozilla Firefox 4.0 and above, Google Chrome, Opera 11
  • 256MB of RAM; 128MB of graphics memory

Linux

  • 2.33GHz or faster x86-compatible processor, or Intel Atom 1.6GHz or faster processor for netbooks
  • Red Hat® Enterprise Linux (RHEL) 5.6 or later (32-bit and 64-bit), openSUSE® 11.3 or later (32-bit and 64-bit), Ubuntu 10.04 or later (32-bit and 64-bit)
  • Mozilla Firefox 4.0 or Google Chrome
  • 512MB of RAM; 128MB of graphics memory

Solaris

  • 1600 MHz Sun™ UltraSPARC® IIIi or faster processor
  • Solaris™ 10
  • Mozilla Firefox 4.0
  • 2GB of RAM; 128MB of graphics memory

Android

  • ARMv7 processor with vector FPU, minimum 550MHz, OpenGL ES 2.0, H.264 and AAC HW decoders
  • Android™ 2.2, 2.3, 3.0, 3.1, 3.2, and 4.0
  • 256MB of RAM
  • Android web browser

BlackBerry Tablet OS

  • BlackBerry PlayBook and a version of the BlackBerry® Tablet OS that supports Adobe® Flash® Player 11

Flash Access Clients

  • Microsoft® Windows XP (32-bit), Windows Vista® (32-bit and 64-bit), or Windows 7 (32-bit and 64-bit)
  • Mac OS X v10.6, v10.7 (32-bit and 64-bit) Linux®: openSUSE® 11.3 or greater (32-bit and 64-bit); Red Hat® Enterprise Linux (RHEL) 5.6 or greater (32-bit and 64-bit); or Ubuntu 10.04 or greater (32-bit and 64-bit)